postgresql@18
18.6Object-relational database system
Install
brew install postgresql@18Details
Sources
Supported platforms
| Architecture | Platforms | Version | Download |
|---|---|---|---|
| Apple Silicon | Golden Gate | 18.6 | FileSHA-25631b40a10b68e4e69350a26f7033ea5c68c3360512ae61393ba1d801d7770c480 |
| Apple Silicon | Tahoe | 18.6 | FileSHA-256b526e79ca83b7c161a391585e70148c5aa45c53a8f593b398bc4a281f6922bd9 |
| Apple Silicon | Sequoia | 18.6 | FileSHA-2566c47c97af81964d3486cee9f3d96a1b188313c3fec11df649229173f3cff7074 |
| ARM64 | Linux | 18.6 | FileSHA-256aa9448fe3baa684e6e8191a8fb5546aa2a4aac1c6f6ce15d7aa5c2feb05c973b |
| x86_64 | Linux | 18.6 | FileSHA-25662d39ad0ec43d4a82a3053d5d6e8d22536aff66d5c936617cfc222b6c2991ceb |
Dependencies
- icu4c@78
- krb5
- lz4
- openssl@3
- readline
- zstd
- gettext
Package data
Caveats
This formula has created a default database cluster with: initdb --locale=en_US.UTF-8 -E UTF-8 $HOMEBREW_PREFIX/var/postgresql@18 When uninstalling, some dead symlinks are left behind so you may want to run: brew cleanup --prune-prefix If the service fails to start with a "postmaster.pid" lock file error after an unclean shutdown, and no postgres is running, remove the stale file: rm $HOMEBREW_PREFIX/var/postgresql@18/postmaster.pid
